Scheduling the one-off and recurring collection of individual parcels via PostNL's Collection Service is currently not working

Incident Report for MyParcel

Resolved

PostNL has resolved the problem, which is confirmed by us.
Posted Jun 10, 2026 - 09:17 CEST

Update

PostNL is still working hard on a solution, the root cause is not determined yet.
Posted Jun 09, 2026 - 17:29 CEST

Update

PostNL is still working hard on a solution
Posted Jun 09, 2026 - 14:36 CEST

Identified

PostNL is currently working hard on a solution
Posted Jun 09, 2026 - 11:23 CEST
This incident affected: Carriers (PostNL | Collection Service).