Performance degradation

Incident Report for MyParcel

Resolved

The issue is solved; the performance is back to normal.
Posted Jun 01, 2026 - 12:17 CEST

Update

We are still investigating the performance degradation.
Posted Jun 01, 2026 - 10:58 CEST

Investigating

We are experiencing performance degradation and are investigating it.
Posted Jun 01, 2026 - 10:00 CEST
This incident affected: API (Shipments, Delivery options, Webhooks) and Backoffice.