Shipment Overview Unavailable

Incident Report for MyParcel

Resolved

This incident has been resolved.
Posted Mar 31, 2025 - 08:55 CEST

Investigating

We are currently experiencing an issue that prevents access to the shipment overview and viewing of shipments.
Posted Mar 31, 2025 - 08:48 CEST
This incident affected: Backoffice.