Temporary outage: European return label via PostNL not available

Incident Report for MyParcel

Resolved

This incident has been resolved.
Posted Sep 05, 2025 - 17:48 CEST

Identified

Unfortunately, creating a European return label is currently not possible. PostNL is working hard on a solution and is doing everything possible to resolve this issue as soon as possible.
Posted Sep 05, 2025 - 15:29 CEST
This incident affected: API (Shipments, Easy Return Service Europe PostNL) and Websites (MyParcel NL).