PostNL status updates delayed
Incident Report for MyParcel
Resolved
This incident has been resolved by PostNL
Posted Sep 19, 2022 - 15:08 CEST
Monitoring
PostNL stated that the issue is resolved.
Posted Sep 19, 2022 - 14:12 CEST
Investigating
PostNL is investigating this issue
Posted Sep 19, 2022 - 13:30 CEST
This incident affected: Third parties (PostNL | Shipment status update).