Mailbox international

Incident Report for MyParcel

Resolved

This incident has been resolved.
Posted Feb 13, 2026 - 13:14 CET

Update

The issue turned out to be on MyParcel's side. We are working on a solution.
Posted Feb 13, 2026 - 12:23 CET

Identified

You're temporarily unable to create international mailbox parcels. Mailbox parcels within the Netherlands can still be created as usual. PostNL is working on a solution. We'll keep you updated.
Posted Feb 13, 2026 - 11:07 CET
This incident affected: Carriers (PostNL | Create digital stamp / mailbox).