Not possible to download DPD shipment labels
Incident Report for MyParcel
Resolved
This incident has been resolved.
Posted Apr 09, 2024 - 19:27 CEST
Investigating
We are currently investigating this issue.
Posted Apr 09, 2024 - 16:56 CEST
This incident affected: Third parties (DPD).