The MyParcel API and components using it (like the Backoffice) are slow

Incident Report for MyParcel

Resolved

This incident has been resolved.
Posted Mar 30, 2026 - 18:13 CEST

Update

The MyParcel API and components using it (like the Backoffice) are slow, instead of down.
Posted Mar 30, 2026 - 17:25 CEST

Identified

We identified the component which is causing the current issue, it concerns a specific AWS service. We are currently in close contact with AWS, to get more details which can help solving the issue.
Posted Mar 30, 2026 - 17:21 CEST

Update

We are still investigating the issue.
Posted Mar 30, 2026 - 16:21 CEST

Investigating

We are currently investigating this issue.
Posted Mar 30, 2026 - 15:39 CEST
This incident affected: API (Shipments, Delivery options, Email services, Webhooks, Easy Return Service Europe PostNL) and Backoffice.