Not possible to create DPD shipments

Incident Report for MyParcel

Resolved

This incident has been resolved.
Posted Apr 14, 2025 - 12:13 CEST

Identified

Issue is at DPD side.
Posted Apr 14, 2025 - 10:32 CEST

Investigating

We are currently investigating this issue.
Posted Apr 14, 2025 - 10:31 CEST
This incident affected: Carriers (DPD).