Unable to login
Incident Report for MyParcel
Resolved
This incident has been resolved.
Posted May 04, 2023 - 07:52 CEST
Investigating
We are currently investigating this issue.
Posted May 04, 2023 - 07:41 CEST
This incident affected: Backoffice.