PostNL delivery_options / pickup_locations major outage
Incident Report for MyParcel
Resolved
This incident has been resolved.
Posted Mar 22, 2023 - 13:58 CET
Update
All outages are resolved.
Posted Mar 22, 2023 - 13:58 CET
Update
We are continuing to investigate this issue.
Posted Mar 22, 2023 - 13:19 CET
Investigating
We are currently investigating this issue.
Posted Mar 22, 2023 - 12:54 CET
This incident affected: Third parties (PostNL | Delivery options, PostNL | Pickup locations).