Fetching of dates and times for delivery options for PostNL is currently not working

Incident Report for MyParcel

Resolved

We managed to fix the issue ourselves, delivery options are working as expected now.
Posted May 24, 2025 - 01:18 CEST

Update

We managed to fix the issue ourselves, delivery options are working as expected now.
Posted May 24, 2025 - 01:17 CEST

Identified

PostNL identified the issue and planned to have the issue fixed Monday 26th of May in the morning.
Posted May 23, 2025 - 16:37 CEST

Update

PostNL is investigating the issue.
Posted May 23, 2025 - 12:54 CEST

Investigating

We are currently investigating this issue.
Posted May 23, 2025 - 09:28 CEST
This incident affected: Carriers (PostNL | Delivery options).