Not possible to create DPD shipments

Incident Report for MyParcel

Resolved

This incident has been resolved.
Posted Apr 13, 2025 - 15:48 CEST

Identified

At the moment, it is not possible to create shipments via DPD due to an issue on DPD’s side. We hope the problem will be resolved soon.
We will inform you as soon as there is an update.
Posted Apr 12, 2025 - 13:26 CEST
This incident affected: Carriers (DPD).